Skip to main content
VulnerabilityPublished Updated

CVE-2026-70630: Libav · FFmpeg versions from 3.0 up to, but not including, 9.0 contain an uninitialized heap memory read vulnerability in the native Screenpresso decoder

Affects libavSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.5 Medium · fixed in 9.0 : update libav when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0, 7:4.2.7-0ubuntu0.1+esm17, 7:4.4.2-0ubuntu0.22.04.1+esm16
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade ffmpeg/FFmpeg to 9.0; the Ubuntu ffmpeg package to 7:4.2.7-0ubuntu0.1+esm17; the Ubuntu ffmpeg package to 7:4.4.2-0ubuntu0.22.04.1+esm16.

Affected software

ProductAffectedFixed in
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threatsAffected
  • >=3.0 <9.0
Fixed in
  • 9.0
Ubuntu Pro 14.04 LTSlibavpkg:deb/ubuntu/libav?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 6:0.8.7-1ubuntu2 – 6:9.20-0ubuntu0.14.04.1+esm1
14 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 7:2.7.2-1build1 – 7:2.8.17-0ubuntu0.1+esm18
36 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 7:3.3.4-2 – 7:3.4.11-0ubuntu0.1+esm16
30 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/focalOther threatsAffected
  • <7:4.2.7-0ubuntu0.1+esm17
Fixed in
  • 7:4.2.7-0ubuntu0.1+esm17
Ubuntu Pro 22.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <7:4.4.2-0ubuntu0.22.04.1+esm16
Fixed in
  • 7:4.4.2-0ubuntu0.22.04.1+esm16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Ubuntu provides patched FFmpeg packages via Ubuntu Pro Extended Security Maintenance (ESM) for affected releases including 20.04 LTS and 22.04 LTS. Users should update to the fixed package versions listed in the Ubuntu advisory USN-8750-1. Standard system updates via Ubuntu Pro ESM will apply the necessary remediation. No additional mitigation actions are required beyond applying these updates.

Description

FFmpeg versions from 3.0 up to, but not including, 9.0 contain a vulnerability in the native Screenpresso decoder that allows reading uninitialized heap memory. This occurs because the decoder does not validate the decompressed byte count before copying frame data, potentially exposing sensitive memory contents such as userspace addresses. The vulnerability can be triggered by supplying a crafted SPV1 packet with a valid zlib stream that decompresses fewer bytes than expected. A fix is available through updated packages provided by Ubuntu Pro via Extended Security Maintenance (ESM).

References

Community reviews

Loading reviews…