Skip to main content
VulnerabilityPublished Updated

CVE-2026-70632: Libav · FFmpeg versions from 4.4 up to, but not including, 9.0 contain an out-of-bounds heap write vulnerability in the native GoPro CineForm HD (CFHD)

Affects libavSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High · fixed in 9.0 : patch libav soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0, 7:4.4.2-0ubuntu0.22.04.1+esm14, 7:6.1.1-3ubuntu5+esm12 +1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threatsAffected
  • >=4.4 <9.0
Fixed in
  • 9.0
Ubuntu Pro 14.04 LTSlibavpkg:deb/ubuntu/libav?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 6:0.8.7-1ubuntu2 – 6:9.20-0ubuntu0.14.04.1+esm1
14 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <7:4.4.2-0ubuntu0.22.04.1+esm14
Fixed in
  • 7:4.4.2-0ubuntu0.22.04.1+esm14
Ubuntu Pro 24.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <7:6.1.1-3ubuntu5+esm12
Fixed in
  • 7:6.1.1-3ubuntu5+esm12
Ubuntu 26.10ffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=stonkingOther threatsAffected
  • =7:8.0.1-3ubuntu2
  • =7:8.1-3ubuntu3
  • =7:8.1.2-2ubuntu2
Fixed in–
Ubuntu Pro 26.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <7:8.0.1-3ubuntu2+esm3
Fixed in
  • 7:8.0.1-3ubuntu2+esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Ubuntu has issued security advisories and provides patches for affected versions in their LTS releases. Users should apply these official updates promptly to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

FFmpeg versions from 4.4 up to, but not including, 9.0 contain an out-of-bounds heap write vulnerability in the native GoPro CineForm HD (CFHD) decoder. This vulnerability allows remote attackers to corrupt heap memory by supplying a crafted AVI file during stream probing. The flaw is due to the cfhd_decode() function not enforcing a logical output-width invariant, leading to writes beyond the allocated output buffer. Ubuntu has issued security advisories and provides patches for affected versions in their LTS releases.

References

Community reviews

Loading reviews…