Skip to main content
VulnerabilityPublished Updated

CVE-2024-4128: Firebase cli · Firebase vulnerable to CRSF attack

Affects firebase-cliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 2.6 Low : upgrade to 13.6.0 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
2.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 13.6.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade firebase-cli to 13.6.0.

Affected software

ProductAffectedFixed in
Homebrewfirebase-clipkg:brew/firebase-cliOther threatsAffected
  • >=3.6.1 <13.6.0
Fixed in
  • 13.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade firebase-cli to version 13.6.0 or later, which contains the official fix for this vulnerability. Users running affected versions (>=3.6.1 <13.6.0) should update promptly to prevent potential data exfiltration via CSRF attacks. No other mitigations are specified or required.

Description

CVE-2024-4128 is a low-severity vulnerability in the Firebase CLI emulator suite that allows a potential Cross-Site Request Forgery (CSRF) attack. The issue arises from an export endpoint used to export data from running emulators. If a user runs the emulator and visits a malicious website on a browser that permits calls to localhost (notably Chrome versions before v94), the website could exfiltrate emulator data. This vulnerability affects firebase-cli versions from 3.6.1 up to but not including 13.6.0. The issue is fixed in version 13.6.0.

References

Community reviews

Loading reviews…