MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server
Affects mcp-inspectorSource GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 0.16.6 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.16.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade mcp-inspector to 0.16.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-inspectorpkg:brew/mcp-inspectorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade MCP Inspector to version 0.16.6 or later, which includes hardened URL handling and validation that prevents script injection and command execution. Since a patch is available and fixed in 0.16.6, applying this official fix is the recommended remediation. Avoid connecting the Inspector to untrusted MCP servers until patched.
Description
MCP Inspector versions 0.14.2 up to but not including 0.16.6 contain a cross-site scripting (XSS) vulnerability. This flaw occurs when the tool renders a redirect URL from a remote MCP server without sufficient validation. If the Inspector connects to an untrusted server, an attacker can craft a redirect that injects malicious script into the Inspector's context. This script can then leverage the built-in proxy to execute arbitrary commands on the developer's machine. Version 0.16.6 includes hardened URL handling and validation that prevents this script execution.
References
- github.com/modelcontextprotocol/inspector/security/advisories/GHSA-g9hg-qhmf-q45m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-58444 (opens in a new tab)
- github.com/modelcontextprotocol/inspector/commit/650f3090d26344a672026b737d81586595bb1f60 (opens in a new tab)
- github.com/modelcontextprotocol/inspector (opens in a new tab)
- npmjs.com/package/@modelcontextprotocol/inspector/v/0.16.6 (opens in a new tab)