Skip to main content
VulnerabilityPublished Updated

CVE-2026-56275: Flowise Execute Flow function has an SSRF vulnerability

Affects flowiseSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 3.1.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade flowiseai/Flowise and flowise and flowise-components to 3.1.0.

Affected software

ProductAffectedFixed in
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0
npmflowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
npmflowise-componentsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for Flowise that addresses this SSRF vulnerability by ensuring secureFetch is called for verification. Users should upgrade to version 3.1.0 or later where this issue is fixed. No additional mitigations are indicated by the vendor advisory.

Description

Flowise versions prior to 3.1.0 contain a Server-Side Request Forgery (SSRF) vulnerability in the Execute Flow function. An attacker can supply an intranet address via the base URL field, bypassing internal checks, causing the server to make HTTP requests to internal network addresses. This may allow attackers to enumerate internal services, access sensitive management interfaces, or leak confidential information. A fix is available that involves calling secureFetch for verification.

References

Community reviews

Loading reviews…