Skip to main content
VulnerabilityPublished Updated

Flowise has an Arbitrary File Read

Affects flowiseSource GCVE Database

0

CVSS 9.1 Critical : upgrade to 3.0.6 as a priority.

Data as of 22 Jul 2026, 00:55 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

What to do

Upgrade flowise to 3.0.6.

Affected software

ProductAffectedFixed in
npmflowiseAffected
  • >=3.0.5 <3.0.6
  • =3.0.5
Fixed in
  • 3.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Flowise version 3.0.6. Users should upgrade to 3.0.6 or later to remediate this vulnerability. Until patched, restrict access to the affected endpoints and ensure that only trusted users can supply chatflowId values. Monitor for unusual file access patterns related to these endpoints. Patch status is confirmed by the version range indicating the vulnerability is fixed starting from 3.0.6.

Description

Flowise versions 3.0.5 up to but not including 3.0.6 contain an arbitrary file read vulnerability in the chatId parameter of two API endpoints. This flaw allows unauthenticated users with knowledge of a valid chatflowId UUID to read arbitrary files on the local filesystem, including the default SQLite database file. The vulnerability arises from insufficient validation of the chatId parameter combined with fallback logic that bypasses directory restrictions. Exploitation can lead to disclosure of sensitive data such as API keys stored in the database and causes denial of service by corrupting file access until server restart.

References

Community reviews

Loading reviews…