Skip to main content
VulnerabilityPublished Updated

CVE-2025-66034: fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib

Affects fonttoolsSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 4.63.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.63.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade fonttools to 4.63.0.

Affected software

ProductAffectedFixed in
Homebrewfonttoolspkg:brew/fonttoolsOther threatsAffected
  • <4.63.0
Fixed in
  • 4.63.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade fontTools to version 4.63.0 or later to remediate this vulnerability. The patch is available and should be applied promptly. No additional vendor advisories indicate alternative mitigations or that no action is required.

Description

fontTools, a Python library for font manipulation, has an arbitrary file write vulnerability in its varLib module affecting versions from 4.33.0 up to but not including 4.63.0. This flaw allows remote code execution when processing a malicious .designspace file via the varLib CLI or any code invoking fontTools.varLib.main(). The vulnerability has been fixed in version 4.63.0.

References

Community reviews

Loading reviews…