For an updatable cursor over a table without OIDs that has an auto-increment int4 column, psqlODBC places that
Source GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 18.00.0006 when convenient.
Data as of 2 Nov 2026, 23:28 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 6.8 |
|---|
- Patch
- Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade psqlODBC to 18.00.0006.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQLpsqlODBC | Affected
| Fixed in
|
GitHubpsqlODBCpkg:github/psqlODBCOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade psqlODBC to version 18.00.0006 or later where this vulnerability is fixed. No other mitigation or workaround is provided. Since the vulnerability arises from unsafe format string usage, patching the driver is necessary to prevent exploitation.
Description
A vulnerability in psqlODBC versions before 18.00.0006 allows an attacker to cause application crashes or leak client memory. This occurs when an updatable cursor over a table without OIDs has an auto-increment int4 column whose name contains format string directives. The driver improperly uses this column name in a printf-style format string, leading to memory read issues during query construction.