FreeRDP 2.0.0 before 3.32.2 contains an out-of-bounds read vulnerability in freerdp_dsp_decode_gsm610 that allows
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.32.2 when convenient.
Data as of 3 Nov 2026, 16:44 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.3 |
- Patch
- Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade FreeRDP to 3.32.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreeRDPFreeRDP | Affected
| Fixed in
|
AI-suggested
A fix for this vulnerability is available in FreeRDP version 3.32.2. Users should upgrade to version 3.32.2 or later to remediate this issue. No other mitigation or workaround is indicated.
Description
FreeRDP versions from 2.0.0 up to but not including 3.32.2 contain an out-of-bounds read vulnerability in the freerdp_dsp_decode_gsm610 function. This flaw allows a malicious RDP server to send specially crafted truncated GSM610 audio frames that cause the client to read beyond the intended audio buffer. Such malformed frames can lead to a client crash when negotiating GSM610 audio codec and sending short WAVE2 messages.