Skip to main content
CVE-2026-85090VulnerabilityPublished Updated

FreeRDP before 3.31.0 contains a heap out-of-bounds read vulnerability in the general_ChromaV1ToYUV444 function during AVC444 chroma plane reconstruction

Affects freerdpSource GCVE Database

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 3.31.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.31.0+dfsg-0ubuntu0.24.04.1, 3.31.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu freerdp3 to 3.31.0+dfsg-0ubuntu0.24.04.1 (package) or 3.31.0+dfsg-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threatsAffected
  • <3.31.0+dfsg-0ubuntu0.26.04.1
Fixed in
  • 3.31.0+dfsg-0ubuntu0.26.04.1
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.31.0+dfsg-0ubuntu0.24.04.1
Fixed in
  • 3.31.0+dfsg-0ubuntu0.24.04.1
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.10.0+dfsg1-1.1ubuntu1 – 2.11.5+dfsg1-1ubuntu0.1~esm6
12 affected builds
Fixed in–
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • 2.3.0+dfsg1-2build1 – 2.6.1+dfsg1-3ubuntu2.11
23 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.0.0~git20190204.1.2693389a+dfsg1-1 – 2.6.1+dfsg1-0ubuntu0.20.04.2+esm4
17 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.0.0~git20170725.1.1648deb+dfsg1-1 – 2.2.0+dfsg1-0ubuntu0.18.04.4+esm6
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users and administrators should upgrade FreeRDP to version 3.31.0 or later to remediate the issue. Applying the official vendor patches or updated packages from trusted sources is recommended. No additional mitigation actions are specified or required beyond applying the fix.

Description

FreeRDP before 3.31.0 contains a heap out-of-bounds read vulnerability in the general_ChromaV1ToYUV444 function during AVC444 chroma plane reconstruction. A malicious RDP server can craft a RFX_AVC444_BITMAP_STREAM with specific frame geometry to trigger an out-of-bounds memory read past the allocated luma plane.

References

Community reviews

Loading reviews…