CVE-2026-121960: FreeRDP before 3.32.2 contains a denial of service vulnerability in the NLA-enabled shadow server
Affects FreeRDPSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 3.32.2 soon.
Data as of 4 Nov 2026, 19:44 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade freerdp/FreeRDP to 3.32.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FreeRDP to version 3.32.2 or later where this vulnerability is fixed. No other mitigations or workarounds are specified.
Description
FreeRDP versions before 3.32.2 have a denial of service vulnerability in the NLA-enabled shadow server. This occurs when a CredSSP TSRequest omits negoTokens, allowing unauthenticated attackers to send a crafted seven-byte TSRequest that triggers a fatal assertion and crashes the server process.