From 0.13 until 1.8.0, authlib.common.security.is_secure_transport() uses a textual prefix comparison for loopback
Affects authlibSource GCVE Database
Not known to be exploited · CVSS 2.6 Low : upgrade to 1.8.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 2.6 |
|---|
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authlib to 1.8.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIauthlibpkg:pypi/authlibOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Authlib to version 1.8.0 or later, where this issue is fixed. The vendor has released an official patch addressing the flawed is_secure_transport() implementation. No additional mitigations are indicated as the vulnerability is resolved by this update.
Description
Authlib versions from 0.13 up to but not including 1.8.0 contain a vulnerability in the is_secure_transport() function, which uses a textual prefix comparison for loopback HTTP exemptions. This flaw allows an attacker who can supply a URL to certain OIDC operations to bypass the TLS requirement and cause cleartext redirection or acceptance of cleartext endpoints. The vulnerability does not bypass redirect URI exact matching and does not enable token forgery or user authentication bypass. The issue is fixed in version 1.8.0.