Authlib: Prior to 1.9.0, OpenIDMixin.parse_id_token() reads the nonce_supported decision from the untrusted ID token
Affects authlibSource GCVE Database
Not known to be exploited · CVSS 4.2 Medium : upgrade to 1.9.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.2 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authlib to 1.9.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIauthlibpkg:pypi/authlibOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Authlib to version 1.9.0 or later, where this vulnerability is fixed. The fix removes the trust on the nonce_supported claim from the untrusted ID token in OpenIDMixin.parse_id_token(). No other mitigations are indicated or required.
Description
Authlib versions prior to 1.9.0 contain a vulnerability in OpenIDMixin.parse_id_token() where the nonce_supported decision is read from an untrusted ID token. This flaw allows an attacker with a captured validly signed token to bypass nonce-to-session binding and replay the token into an attacker-controlled session in implicit and hybrid flows. The vulnerability does not affect the plain authorization code flow and requires the token to pass signature, issuer, and audience validation. The issue is fixed in version 1.9.0.
References
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)
- github.com/authlib/authlib/commit/6563f6f7a8c2f71d2f85ee7511d72a4fbae3acc0 (opens in a new tab)
- github.com/authlib/authlib/pull/949 (opens in a new tab)
- github.com/authlib/authlib/security/advisories/GHSA-c5mf-xmp2-59rc (opens in a new tab)