From 1.3.1 until 1.9.0, OctKey.import_key() checks asymmetric-key markers only at byte zero while Authlib's PEM
Affects authlibSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.4 High : upgrade to 1.9.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.4 |
|---|
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authlib to 1.9.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIauthlibpkg:pypi/authlibOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Authlib to version 1.9.0 or later, where the issue in OctKey.import_key() is fixed. The patch corrects key validation to properly handle PEM keys with leading whitespace, comments, or byte-order marks, preventing token forgery.
Description
Authlib versions from 1.3.1 up to but not including 1.9.0 contain a vulnerability in the OctKey.import_key() function. The function only checks asymmetric-key markers at the first byte, while PEM loaders accept leading whitespace, comments, or byte-order marks. This discrepancy allows an attacker who knows the public key bytes with such prefixes to use them as an HMAC secret and forge HS256 tokens with arbitrary claims. This vulnerability bypasses the remediation for CVE-2024-37568 and is fixed in version 1.9.0.
References
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)
- github.com/authlib/authlib/commit/e3bd41cb29dcfee434453b135ffb487884baeedf (opens in a new tab)
- github.com/authlib/authlib/pull/945 (opens in a new tab)
- github.com/authlib/authlib/security/advisories/GHSA-7vr2-2fgp-9w7p (opens in a new tab)