Skip to main content
CVE-2026-114618VulnerabilityPublished Updated

Authlib: Prior to 1.9.0, the default RFC 7523 JWTBearerGrant.get_audiences() returns an empty list, causing

Affects authlibSource GCVE Database

0
Compare
Authoritative record:CVE-2026-114618· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.9.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.8
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade authlib to 1.9.0.

Affected software

ProductAffectedFixed in
PyPIauthlibpkg:pypi/authlibOther threatsAffected
  • <1.9.0
Fixed in
  • 1.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Authlib to version 1.9.0 or later, where this issue is fixed. Alternatively, ensure that the get_audiences() method is overridden to return the server's valid audience identifiers to prevent misuse. Since a patch is available and the vulnerability is fixed in 1.9.0, applying the official update is the recommended remediation.

Description

Authlib versions prior to 1.9.0 have a vulnerability in the default implementation of JWTBearerGrant.get_audiences() where it returns an empty list. This causes the verify_claims() method to only check for the presence of an aud claim without verifying it matches the current authorization server. As a result, an attacker with a valid assertion for another service sharing the signing key can obtain an access token from the vulnerable server. This issue is fixed in Authlib version 1.9.0.

References

Community reviews

Loading reviews…