Skip to main content
VulnerabilityPublished Updated

CVE-2024-44070: frr vulnerabilities

Affects frrSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-44070· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 7.2.1-1ubuntu0.2+esm3 : patch frr as a priority.

Data as of 6 Nov 2026, 06:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
Patch
Available – fixed in 7.2.1-1ubuntu0.2+esm3, 8.1-1ubuntu1.13, 8.4.4-1.1ubuntu6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Ubuntu frr to 7.2.1-1ubuntu0.2+esm3 (package) or 8.1-1ubuntu1.13 (package) or 8.4.4-1.1ubuntu6.3 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.3
Fixed in
  • 8.4.4-1.1ubuntu6.3
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.13
Fixed in
  • 8.1-1ubuntu1.13
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • <7.2.1-1ubuntu0.2+esm3
Fixed in
  • 7.2.1-1ubuntu0.2+esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by Ubuntu by updating FRR packages to the fixed versions listed in the vendor advisory. For Ubuntu 20.04 LTS, upgrade to frr version 7.2.1-1ubuntu0.2+esm3 or later. For Ubuntu 22.04 LTS, upgrade to 8.1-1ubuntu1.13 or later. For Ubuntu 24.04 LTS, upgrade to 8.4.4-1.1ubuntu6.3 or later. For Ubuntu 24.10, upgrade to 10.0.1-0.1ubuntu3. Using Ubuntu Pro with ESM Apps provides extended security coverage. No other mitigation is required beyond applying these updates.

Description

Two vulnerabilities in FRRouting (FRR) affect Ubuntu releases including 20.04 LTS, 22.04 LTS, 24.04 LTS, and 24.10. CVE-2024-44070 involves improper handling of certain BGP messages that can cause FRR to crash, resulting in denial of service. CVE-2024-55553 involves re-validation of all routes when an internal socket buffer overflows, potentially degrading performance and causing denial of service. Fixes are available in updated FRR package versions for the affected Ubuntu releases.

References

Community reviews

Loading reviews…