Skip to main content
CVE-2024-55553VulnerabilityPublished Updated

In FRRouting (FRR) before 10.3 from 6.0 onward, all routes are re-validated if the total size of an update received

Affects frrSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 7.2.1-1ubuntu0.2+esm5 : patch frr soon.

Data as of 6 Nov 2026, 05:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.2.1-1ubuntu0.2+esm5, 8.1-1ubuntu1.17, 8.4.4-1.1ubuntu6.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Ubuntu frr to 7.2.1-1ubuntu0.2+esm5 (package) or 8.1-1ubuntu1.17 (package) or 8.4.4-1.1ubuntu6.8 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.8
Fixed in
  • 8.4.4-1.1ubuntu6.8
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.17
Fixed in
  • 8.1-1ubuntu1.17
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • <7.2.1-1ubuntu0.2+esm5
Fixed in
  • 7.2.1-1ubuntu0.2+esm5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Update FRR to one of the fixed versions: 7.2.1-1ubuntu0.2+esm5, 8.1-1ubuntu1.17, 8.4.4-1.1ubuntu6.8, or any version from 10.3 onward. Ubuntu security notices USN-7230-2 and USN-7230-3 provide detailed update instructions. Standard system updates will apply the necessary fixes. No additional mitigations are required once patched.

Description

FRRouting (FRR) versions from 6.0 up to but not including 10.3 have a vulnerability where all routes are re-validated if the total size of an RTR update exceeds the internal socket buffer size (default 4K). This can be exploited by an attacker to cause continuous route re-validation, impacting route handling performance and causing denial of service. The issue also increases BMP traffic to ingestors. Fixed versions include 10.0.3, 10.1.2, 10.2.1, and all versions from 10.3 onward.

References

Community reviews

Loading reviews…