CVE-2026-33050: GeoNode has OS command injection via uploaded file layer name
Affects GeoNodeSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 5.1.0 soon.
Data as of 6 Nov 2026, 20:32 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 5.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade GeoNode to 5.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIGeoNode | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GeoNode to version 5.1.0 or later, where this vulnerability is fixed. Since a patch is available and the vulnerability is resolved in the fixed version, applying the official update is the recommended mitigation.
Description
GeoNode versions prior to 5.1.0 are vulnerable to an OS command injection vulnerability via a crafted layer name in an uploaded vector file. This flaw allows an attacker with limited privileges to execute arbitrary operating system commands without user interaction. The vulnerability is addressed in GeoNode version 5.1.0.