Skip to main content
VulnerabilityPublished Updated

CVE-2026-110634: git-diff · OS command injection vulnerability via crafted strings to the gitDiff API

Affects git-diffSource GCVE Database

0
Authoritative record:CVE-2026-110634· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.0.7 as a priority.

Data as of 27 Oct 2026, 17:42 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade git-diff to 2.0.7.

Affected software

ProductAffectedFixed in
npmgit-diffAffected
  • <2.0.7
Fixed in
  • 2.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade git-diff to version 2.0.7 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

git-diff versions prior to 2.0.7 contain a critical OS command injection vulnerability. This flaw allows attackers to execute arbitrary shell commands by supplying specially crafted strings to the gitDiff API. The vulnerability arises because the API evaluates these strings using shelljs.exec with Node.js process privileges. A fix is available in version 2.0.7.

References

Community reviews

Loading reviews…