Skip to main content
CVE-2025-64346VulnerabilityPublished Updated

github.com/jaredallard/archives Has Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Affects github.com/jaredallard/archivesSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64346· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.0.1 when convenient.

Data as of 4 Nov 2026, 18:47 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.0
Patch
Available – fixed in 1.0.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade github.com/jaredallard/archives to 1.0.1.

Affected software

ProductAffectedFixed in
Gogithub.com/jaredallard/archivesAffected
  • <1.0.1
Fixed in
  • 1.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to version 1.0.1 or later, which contains the official fix for this vulnerability. Manual validation of archives before processing is a possible workaround but not recommended compared to applying the patch.

Description

The github.com/jaredallard/archives library before version 1.0.1 contains a path traversal vulnerability that allows a malicious user to craft archives leading to remote code execution or file modification within the context of the running user. The impact severity depends on the permissions of the user running the library and the environment, with higher risk when run as root or in production systems. The vulnerability is fixed in version 1.0.1.

References

Community reviews

Loading reviews…