GitLab Has Remediated an Issue
Affects gitlabSource GCVE Database
Not known to be exploited · CVSS 7.5 High.
Data as of 29 Oct 2026, 22:54 UTC
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 16.04 LTSgitlabpkg:deb/ubuntu/gitlab?arch=source&distro=xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading GitLab CE/EE to versions 18.3.5 or later for the 11.0+ branch, 18.4.3 or later for the 18.4 branch, and 18.5.1 or later for the 18.5 branch. These versions contain the fix for the denial of service vulnerability. No other mitigation is indicated.
Description
A denial of service vulnerability was found in GitLab CE/EE versions from 11.0 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1. The flaw could be triggered by unauthenticated attackers sending specially crafted GraphQL requests with malicious JSON payloads. GitLab has released patches to remediate this issue.