Skip to main content
CVE-2025-11989VulnerabilityPublished Updated

GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.1 High.

Data as of 29 Oct 2026, 23:28 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 16.04 LTSgitlabpkg:deb/ubuntu/gitlab?arch=source&distro=xenialOther threatsAffected
  • =8.4.3+dfsg-9
  • =8.4.3+dfsg-12
  • =8.5.8+dfsg-5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab EE to version 18.3.5 or later if using the 17.6.0 to 18.3.x series, to 18.4.3 or later if using the 18.4 series, or to 18.5.1 or later if using the 18.5 series. These versions contain the official fix for this vulnerability.

Description

A vulnerability in GitLab EE versions from 17.6.0 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 allows an authenticated attacker to execute unauthorized quick actions by injecting malicious commands in specific descriptions. This issue has been remediated in the stated fixed versions.

References

Community reviews

Loading reviews…