Skip to main content
CVE-2025-11974VulnerabilityPublished Updated

GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 18.3.5 : update gitlab when convenient.

Data as of 29 Oct 2026, 22:54 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 18.3.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 16.04 LTSgitlabpkg:deb/ubuntu/gitlab?arch=source&distro=xenialOther threatsAffected
  • =8.4.3+dfsg-9
  • =8.4.3+dfsg-12
  • =8.5.8+dfsg-5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading GitLab CE/EE to versions 18.3.5, 18.4.3, or 18.5.1 or later remediates this vulnerability. Users should apply these official fixes to prevent denial of service attacks. No additional mitigation actions are indicated by the vendor advisory.

Description

A vulnerability in GitLab CE/EE versions from 11.7 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 allows an unauthenticated attacker to cause a denial of service by uploading large files to specific API endpoints. The issue has been remediated in the specified fixed versions.

References

Community reviews

Loading reviews…