Skip to main content
CVE-2026-78675VulnerabilityPublished Updated

snakemake · GitPython: Arbitrary local file content disclosure via [include] directive in untrusted .gitmodules

Affects snakemakeSource GCVE Database

0
Authoritative record:CVE-2026-78675· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 9.25.2 soon.

Data as of 26 Oct 2026, 19:27 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.25.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snakemake to 9.25.2.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=5.5.3 <9.25.2
Fixed in
  • 9.25.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 9.25.2. Users should upgrade to this version or later to mitigate the vulnerability. The fix involves disabling merge_includes when parsing .gitmodules to prevent following attacker-controlled include directives. Until upgrading, avoid processing untrusted repositories with GitPython or handle exceptions carefully to avoid leaking file contents.

Description

GitPython versions from 5.5.3 up to but not including 9.25.2 contain a vulnerability where the SubmoduleConfigParser used to parse the .gitmodules file follows [include] directives by default. Since .gitmodules is attacker-controlled in cloned repositories, this allows an attacker to cause the parser to read arbitrary local files. When the included file is not a valid git-config format, the parser raises an exception that leaks the first line of the file in the error message. This leads to local file content disclosure of the first line of any readable file on the victim system during common read-only operations like enumerating submodules.

References

Community reviews

Loading reviews…