cruft · GitPython: Incomplete unsafe_git_clone_options denylist omits --template enabling arbitrary command execution via
Affects cruftSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 2.16.0_12 soon.
Data as of 26 Oct 2026, 17:43 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.16.0_12
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade cruft to 2.16.0_12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcruftpkg:brew/cruftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 2.16.0_12 that adds --template to the unsafe_git_clone_options denylist, preventing this attack vector. Users should upgrade to version 2.16.0_12 or later. No other mitigation is required as the vulnerability is addressed by this fix.
Description
GitPython versions up to 3.1.53 have an incomplete denylist for unsafe git clone options that omits the --template option. This omission allows an attacker who can influence clone options and stage a malicious post-checkout hook in a directory to achieve arbitrary OS command execution during a git clone operation. The vulnerability requires the attacker to have write access to a directory used as a template containing executable hooks. A fix is available in version 2.16.0_12 that adds --template to the denylist.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-6p8h-3wgx-97gf (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2180 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/ffcb5359e87619f4fe4a70a4aff5f08c5580ba97 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.54 (opens in a new tab)