cruft · GitPython: Incomplete unsafe_git_revision_options denylist omits --contents/-S, enabling arbitrary file read via
Affects cruftSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2.16.0_15 soon.
Data as of 26 Oct 2026, 17:43 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.16.0_15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade cruft to 2.16.0_15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcruftpkg:brew/cruftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 2.16.0_15 that addresses this issue by updating the unsafe_git_revision_options denylist to include --contents and -S options or by adopting an allowlist approach. Users should upgrade to version 2.16.0_15 or later. Until patched, avoid passing untrusted input to the revision parameter of Repo.blame() or Repo.blame_incremental().
Description
GitPython versions up to 3.1.58 have an incomplete denylist for unsafe git revision options in the Repo.blame() and Repo.blame_incremental() methods. This allows an attacker to use the --contents or -S options to cause arbitrary local file reads, exposing file contents in the blame output. The vulnerability arises because the denylist only blocks file-write options (--output/-o) but omits these read-capable options. A fix is available in version 2.16.0_15.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-5xxx-qhh7-9287 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-78678 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/gitpython/PYSEC-2026-3788.yaml (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-arbitrary-file-read-via-repo-blame (opens in a new tab)