Skip to main content
CVE-2026-78678VulnerabilityPublished Updated

legit · GitPython: Incomplete unsafe_git_revision_options denylist omits --contents/-S, enabling arbitrary file read via

Affects legitSource GCVE Database

0
Authoritative record:CVE-2026-78678· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 1.2.0.post0_15 soon.

Data as of 26 Oct 2026, 19:12 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.0.post0_15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade legit to 1.2.0.post0_15.

Affected software

ProductAffectedFixed in
Homebrewlegitpkg:brew/legitOther threatsAffected
  • >=0.1.0 <1.2.0.post0_15
Fixed in
  • 1.2.0.post0_15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 1.2.0.post0_15 that addresses this vulnerability by updating the unsafe git revision options denylist. Users should upgrade to this fixed version or later. Until patched, avoid passing user-influenced revision strings containing options like --contents or -S to the blame methods. The vendor advisory recommends preferring an allowlist approach for blame options or at minimum adding these file-read options to the denylist.

Description

GitPython versions prior to 1.2.0.post0_15 contain a vulnerability in the Repo.blame() and Repo.blame_incremental() methods where an incomplete denylist of unsafe git revision options allows arbitrary local file reads. Specifically, the options --contents and -S, which cause git blame to output the contents of a specified file, are not blocked, enabling an attacker to read arbitrary files on the host system with the privileges of the running process.

References

Community reviews

Loading reviews…