Skip to main content
VulnerabilityPublished Updated

CVE-2026-79675: JVM argument injection bypass via per-call options in the NLTK Stanford wrappers (incomplete fix of CVE-2026-12841)

Affects gptlineSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.8_23 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.8_23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade gptline to 1.0.8_23.

Affected software

ProductAffectedFixed in
Homebrewgptlinepkg:brew/gptlineOther threatsAffected
  • >=1.0.8 <1.0.8_23
Fixed in
  • 1.0.8_23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available that adds validation of JVM options in the per-call java() function, closing the bypass. Users should update to the fixed version of NLTK that includes this patch. Until patched, avoid passing untrusted input to the java_options parameter of the affected Stanford wrapper classes. Do not rely solely on config_java() for JVM option validation, as it does not cover per-call options.

Description

CVE-2026-79675 is a critical vulnerability in the NLTK Stanford Java wrappers where JVM argument injection can bypass the previous fix for CVE-2026-12841. The vulnerability arises because the per-call java() function accepts unvalidated JVM options, allowing dangerous flags to be passed directly to the JVM. This affects four Stanford wrapper classes that accept user-supplied java_options without validation. Exploitation could allow arbitrary code execution via malicious JVM flags. A patch is available that adds validation to the per-call options path.

References

Community reviews

Loading reviews…