Skip to main content
VulnerabilityPublished

CVE-2026-118254: Grid lite · Highcharts Grid parses pagination language options as HTML

Affects @highcharts/grid-liteSource GCVE Database

0
Authoritative record:CVE-2026-118254· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 3.2.0 soon.

Data as of 28 Oct 2026, 21:14 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade @highcharts/grid-lite and @highcharts/grid-pro to 3.2.0.

Affected software

ProductAffectedFixed in
npm@highcharts/grid-liteAffected
  • >=2.0.0 <3.2.0
Fixed in
  • 3.2.0
npm@highcharts/grid-proAffected
  • >=2.0.0 <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Impact The pagination language strings are written into the DOM as markup rather than as text. An attacker who controls those language options can supply elements carrying event handlers, and those handlers execute in the origin of the page hosting the Grid when the pagination controls render. Exploitation requires that untrusted data reach the Grid language configuration and that pagination be enabled on the Grid. ### Workarounds Run this once after loading the Grid, before creating any grid: ```javascript { const Pagination = Grid.Pagination; const escapeLang = (pagination) => { const lang = pagination.lang; if (!lang) { return; } for (const key of ['pageInfo', 'pageSizeLabel']) { if (typeof lang[key] === 'string') { lang[key] = lang[key].replace(/</g, '&lt;'); } } }; for (const name of ['updatePageInfo', 'renderPageSizeSelector']) { const original = Pagination.prototype[name]; Pagination.prototype[name] = function (...args) { escapeLang(this); return original.apply(this, args); }; } } ``` ### Obtaining the patched version The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example `npm install @highcharts/grid-lite@3.2.0`. If you load Highcharts Grid from a CDN, use a versioned URL, for example `https://cdn.jsdelivr.net/npm/@highcharts/grid-lite@3.2.0/grid-lite.js`. For more on each installation method, see the [installation guide](https://www.highcharts.com/docs/grid/installation).

References

Community reviews

Loading reviews…