CVE-2025-21617: guzzlehttp/oauth-subscriber · Guzzle OAuth Subscriber has insufficient nonce entropy
Affects guzzlehttp/oauth-subscriberSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.8.1 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade guzzlehttp/oauth-subscriber to 0.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistguzzlehttp/oauth-subscriber | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade guzzlehttp/oauth-subscriber to version 0.8.1 or later. No workarounds are available. Applying the official fix eliminates the insufficient entropy issue in nonce generation.
Description
The Guzzle OAuth Subscriber before version 0.8.1 generates nonces with insufficient entropy using a non-cryptographically secure pseudorandom source. This weakness can expose servers to replay attacks if TLS is not employed. No workarounds are available. Users should upgrade to version 0.8.1 or later to address this issue.
References
- github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-21617 (opens in a new tab)
- github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53 (opens in a new tab)
- github.com/FriendsOfPHP/security-advisories/blob/master/guzzlehttp/oauth-subscriber/CVE-2025-21617.yaml (opens in a new tab)
- github.com/guzzle/oauth-subscriber (opens in a new tab)
- github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php (opens in a new tab)
- github.com/guzzle/oauth-subscriber/releases/tag/0.8.1 (opens in a new tab)