Skip to main content
VulnerabilityPublished Updated

CVE-2024-53899: Hatch · virtualenv allows command injection through activation scripts for a virtual environment

Affects hatchSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-53899· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 1.13.0 or 1.6.2 soon.

Data as of 27 Oct 2026, 23:28 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.13.0, 1.6.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hatch to 1.13.0 or 1.6.2.

Affected software

ProductAffectedFixed in
Homebrewhatchpkg:brew/hatchOther threatsAffected
  • >=1.2.0 <1.6.2
  • >=1.9.3 <1.13.0
Fixed in
  • 1.6.2
  • 1.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade hatch to version 1.6.2 or later, or 1.13.0 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended mitigation.

Description

A command injection vulnerability exists in virtualenv versions before 20.26.6, specifically affecting the activation scripts for virtual environments. This occurs because magic template strings are not properly quoted during replacement, allowing injection of arbitrary commands. This vulnerability is distinct from CVE-2024-9287. It affects hatch versions >=1.2.0 <1.6.2 and >=1.9.3 <1.13.0. The issue has been fixed in versions 1.6.2 and 1.13.0.

References

Community reviews

Loading reviews…