Hermes agent: pyasn1 has quadratic-time denial of service in constructed string and indefinite-length ANY decoding
Affects hermes-agentSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 2026.4.30 : patch hermes-agent soon.
Data as of 31 Oct 2026, 18:23 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 2026.4.30
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewhermes-agentpkg:brew/hermes-agentOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in hermes-agent version 2026.4.30 that fixes this vulnerability. Users should upgrade to this version or later to remediate the issue. Until patched, applications should implement input validation or resource limits on ASN.1 decoding to mitigate potential CPU exhaustion. No other vendor advisory states that no action is required or that the issue is already mitigated.
Description
In pyasn1 versions 0.6.4 and earlier used by hermes-agent, a quadratic-time denial of service vulnerability exists in the decoding of constructed OCTET STRINGs, constructed character strings, and indefinite-length ANY types. This flaw causes CPU usage to grow quadratically with the number of fragments during ASN.1 decoding, potentially allowing an attacker to exhaust CPU resources by supplying crafted ASN.1 input. The vulnerability affects BER and CER decoding paths and certain non-conforming DER inputs when an asn1Spec is used. No confidentiality or integrity impact is reported. A fix is available in version 2026.4.30.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-9m75-vc3g-4x39 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119195 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/4ce00797c594b59c1fd6b86d9ebc3ba87b7ec9f9 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)