Skip to main content
CVE-2024-43805VulnerabilityPublished Updated

CVE-2024-43805: Jupyter Notebook · HTML Injection

Affects jupyterlabSource GCVE Database

0

Not known to be exploited · CVSS 7.6 High : upgrade to 4.2.5 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.5, 4.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade jupyterlab to 4.2.5; jupyterlab to 4.6.3.

Affected software

ProductAffectedFixed in
Bitnamijupyterlabpkg:bitnami/jupyterlabOther threatsAffected
  • <4.2.5
Fixed in
  • 4.2.5
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • <4.6.3
Fixed in
  • 4.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to JupyterLab v3.6.8 or later, v4.2.5 or later, or Jupyter Notebook v7.2.2 or later. For deployments unable to update immediately, disable the following JupyterLab plugins to reduce risk: @jupyterlab/mathjax-extension:plugin, @jupyterlab/markdownviewer-extension:plugin, and @jupyterlab/mathjax2-extension:plugin. Disabling these plugins will reduce functionality related to Markdown previews and mathematical equation rendering. There is no full workaround for the underlying DOM Clobbering vulnerability.

Description

CVE-2024-43805 is an HTML injection vulnerability in Jupyter Notebook and JupyterLab that enables DOM Clobbering. It requires user interaction by opening a malicious notebook or Markdown file preview. Exploitation allows an attacker to access data available to the victim and perform arbitrary requests as that user. Official patches are available in JupyterLab versions 3.6.8 and 4.2.5, and Jupyter Notebook version 7.2.2. No full workaround exists, but disabling certain plugins can reduce risk for those unable to update promptly.

References

Community reviews

Loading reviews…