Skip to main content
VulnerabilityPublished Updated

CVE-2026-59939: httplib2 · Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling

Affects duplicitySource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.1.0_2 soon.

Data as of 1 Nov 2026, 02:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.1.0_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade duplicity to 3.1.0_2.

Affected software

ProductAffectedFixed in
Homebrewduplicitypkg:brew/duplicityOther threatsAffected
  • >=0.8.05_1 <3.1.0_2
Fixed in
  • 3.1.0_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of httplib2 is available in 3.1.0_2. Users should upgrade to this version or later to mitigate the vulnerability. No other mitigation is described or required as the vulnerability is addressed by the official fix.

Description

The httplib2 HTTP client library is vulnerable to a decompression bomb denial of service (DoS) attack via unbounded gzip or deflate response handling. A malicious HTTP server can send a small compressed payload that decompresses to a very large size in memory, causing the client process to run out of memory or crash. This affects any application using httplib2.Http().request() with untrusted HTTP endpoints. The vulnerability is fixed in version 3.1.0_2.

References

Community reviews

Loading reviews…