Huginn before 2026.11.05 contains a stored cross-site scripting vulnerability in the service_label helper that marks
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2026.11.05 when convenient.
Data as of 5 Nov 2026, 19:48 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.4 |
- Patch
- Available – fixed in 2026.11.05
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade huginn to 2026.11.05.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| huginnhuginn | Affected
| Fixed in
|
GitHubhuginnpkg:github/huginnOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Huginn version 2026.11.05. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation steps are indicated in the provided data.
Description
Huginn versions before 2026.11.05 have a stored cross-site scripting (XSS) vulnerability in the service_label helper. This flaw occurs because unescaped OAuth service display names are marked as html_safe, allowing authenticated attackers to inject JavaScript by connecting an OAuth account with crafted profile fields. When victims attach such accounts to Agents and view them, the malicious script executes, potentially exposing sensitive data such as Credentials, Agents, Events, and admin actions if the victim has administrative privileges.
References
- github.com/huginn/huginn/security/advisories/GHSA-rjw9-xx87-f2ww (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-123094 (opens in a new tab)
- github.com/huginn/huginn/commit/92229a5e7343bfffc740d31e42b9654b212b678b (opens in a new tab)
- github.com/huginn/huginn (opens in a new tab)
- github.com/huginn/huginn/blob/v2026.11.01/app/helpers/application_helper.rb (opens in a new tab)
- github.com/huginn/huginn/releases/tag/v2026.11.05 (opens in a new tab)
- hackmd.io/@leediay/SJtUoLFTfx (opens in a new tab)
- vulncheck.com/advisories/huginn-before-2026.11.05-stored-xss-via-oauth-service-display-name (opens in a new tab)