CVE-2024-34062: Instalooter · tqdm CLI arguments injection attack
Affects instalooterSource GCVE Database
Not known to be exploited · CVSS 3.9 Low : upgrade to 2.4.4_8 when convenient.
Data as of 1 Nov 2026, 22:57 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.21.0, 1.0.8_3, 2.4.4_8
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade instalooter to 2.4.4_8; icloudpd to 1.21.0; gptline to 1.0.8_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewicloudpdpkg:brew/icloudpdOther threats | Affected
| Fixed in
|
Homebrewgptlinepkg:brew/gptlineOther threats | Affected
| Fixed in
|
Homebrewinstalooterpkg:brew/instalooterOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in tqdm version 4.66.3. Users should upgrade to this version or later to remediate the vulnerability. No workarounds are available.
Description
A command injection vulnerability (CVE-2024-34062) exists in the tqdm Python package used by icloudpd. The flaw arises because certain non-boolean CLI arguments are unsafely passed to Python's eval function, allowing arbitrary code execution. This affects icloudpd versions from 1.17.3 up to but not including 1.21.0. A fix is available in tqdm version 4.66.3. No workarounds are available.
References
- github.com/tqdm/tqdm/security/advisories/GHSA-g7vv-2v7x-gj9p (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-34062 (opens in a new tab)
- github.com/tqdm/tqdm/commit/4e613f84ed2ae029559f539464df83fa91feb316 (opens in a new tab)
- github.com/tqdm/tqdm (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PA3GIGHPWAHCTT4UF57LTPZGWHAX3GW6 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QRECVQCCESHBS3UJOWNXQUIX725TKNY6 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VA337CYUS4SLRFV2P6MX6MZ2LKFURKJC (opens in a new tab)