ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security policy bypass caused by an incomplete fix for
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 1.8 Low · fixed in 6.9.13 : update imagemagick when convenient.
Data as of 28 Oct 2026, 22:57 UTC
- Patch
- Available – fixed in 6.9.13
CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in ImageMagick versions 6.9.13-58 and 7.1.2-32 and later. Users should upgrade to these or later versions to remediate the vulnerability. Since the vulnerability is due to an incomplete fix, applying the official patches is necessary to fully address the issue.
Description
ImageMagick versions before 6.9.13-58 and 7.x before 7.1.2-32 contain a security policy bypass vulnerability due to an incomplete fix of a previous bypass issue. This flaw allows an attacker who can supply input to ImageMagick to circumvent configured security policy restrictions, enabling operations that should have been blocked by the policy. The vulnerability has a low severity rating with a CVSS score of 3.9.
References
- ubuntu.com/security/CVE-2026-116145 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-116145 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-4wfv-467j-fqh9 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-32-security-policy-bypass-via-incomplete-fix (opens in a new tab)