Skip to main content
CVE-2026-116146VulnerabilityPublished Updated

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak in the MSL decoder that fails to release

Affects imagemagickSource GCVE Database

0
Authoritative record:CVE-2026-116146· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 6.9.13 : update imagemagick when convenient.

Data as of 28 Oct 2026, 22:57 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.9.13
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threatsAffected
  • 8:7.1.2.18+dfsg1-1 – 8:7.1.2.31+dfsg1-1
4 affected builds
Fixed in–
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 8:7.1.2.3+dfsg1-1 – 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
11 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 8:6.9.11.60+dfsg-1.6ubuntu1 – 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm15
19 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 8:6.9.11.60+dfsg-1.3 – 8:6.9.11.60+dfsg-1ubuntu1
29 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threatsAffected
  • 8:6.9.10.23+dfsg-2.1ubuntu3 – 8:6.9.10.23+dfsg-2.1ubuntu11.11+esm16
36 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 8:6.9.7.4+dfsg-16ubuntu2 – 8:6.9.7.4+dfsg-16ubuntu6.15+esm18
34 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ImageMagick versions 6.9.13-58 and 7.1.2-33 and later. Users should upgrade to these or later versions to remediate the memory leak vulnerability. No additional mitigation steps are indicated.

Description

ImageMagick versions before 6.9.13-58 and 7.x before 7.1.2-33 contain a memory leak vulnerability in the MSL decoder. This flaw causes allocated memory to not be released when processing crafted MSL images, potentially leading to resource exhaustion and denial of service.

References

Community reviews

Loading reviews…