CVE-2026-61465: ImageMagick before 7.1.2-26 and 6.9.13-51 is missing a check for the allowed memory allocation limit
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2-26 or 6.9.13-51 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 4.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-26, 6.9.13-51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade imagemagick/ImageMagick to 7.1.2-26 or 6.9.13-51.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubimagemagick/ImageMagickpkg:github/imagemagick/ImageMagickOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider restricting or monitoring use of matrix-backed operations like -canny on untrusted input to reduce risk of denial of service.
Description
ImageMagick before 7.1.2-26 and 6.9.13-51 is missing a check for the allowed memory allocation limit in matrix-backed operations such as -canny. An attacker can supply a crafted image that causes ImageMagick to allocate more memory than permitted by the configured policy, resulting in a denial of service.