CVE-2026-25982: ImageMagick is free and open-source software used for editing and manipulating digital images
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 8:6.7.7.10-6ubuntu3.13+esm21 : update imagemagick when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8:6.7.7.10-6ubuntu3.13+esm21, 8:6.9.7.4+dfsg-16ubuntu6.15+esm12, 8:6.9.10.23+dfsg-2.1ubuntu11.11+esm10 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 24 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ImageMagick to version 7.1.2-15 or later, or 6.9.13-40 or later, where this vulnerability is fixed. No other mitigation is specified or required according to the available information.
Description
A heap out-of-bounds read vulnerability exists in ImageMagick's coders/dcm.c module prior to versions 7.1.2-15 and 6.9.13-40. This flaw occurs when processing DICOM files with a specific configuration, causing the decoder loop to read beyond the allocated buffer. Exploitation can lead to Denial of Service (application crash) or Information Disclosure (leaking heap memory). The issue is fixed in versions 7.1.2-15 and 6.9.13-40.