Skip to main content
VulnerabilityPublished Updated

CVE-2026-53938: cjose security update

Affects cjoseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-53938· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 0.6.1-17.el9_8.1 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.1-17.el9_8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 0.6.1-17.el9_8.1.

Affected software

ProductAffectedFixed in
AlmaLinux 9cjoseAffected
  • <0.6.1-17.el9_8.1
Fixed in
  • 0.6.1-17.el9_8.1
AlmaLinux 9cjose-develAffected
  • <0.6.1-17.el9_8.1
Fixed in
  • 0.6.1-17.el9_8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in cjose version 0.6.1-17.el9_8.1. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory RHSA-2026:90812 and the update instructions at https://access.redhat.com/articles/11258 for detailed guidance.

Description

A heap buffer overflow vulnerability exists in the AES Key Wrap decryption function of the cjose library, which implements Javascript Object Signing and Encryption (JOSE). This flaw can lead to a denial of service condition. The issue is fixed in cjose version 0.6.1-17.el9_8.1. The vulnerability has been rated as Important by Red Hat Product Security.

References

Community reviews

Loading reviews…