Skip to main content
VulnerabilityPublished

CVE-2026-53939: Critical · mod_auth_openidc:2.3 security update

Affects cjoseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-53939· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 0.6.1-6.module_el8.10.0+4330+15616d81 : patch cjose as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.1-6.module_el8.10.0+4330+15616d81, 2.4.9.4-9.module_el8.10.0+4297+63ae3533
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 0.6.1-6.module_el8.10.0+4330+15616d81 (cjose package, cjose-devel package) or 2.4.9.4-9.module_el8.10.0+4297+63ae3533 (mod_auth_openidc package).

Affected software

ProductAffectedFixed in
AlmaLinux 8cjoseAffected
  • <0.6.1-6.module_el8.10.0+4330+15616d81
Fixed in
  • 0.6.1-6.module_el8.10.0+4330+15616d81
AlmaLinux 8cjose-develAffected
  • <0.6.1-6.module_el8.10.0+4330+15616d81
Fixed in
  • 0.6.1-6.module_el8.10.0+4330+15616d81
AlmaLinux 8mod_auth_openidcAffected
  • <2.4.9.4-9.module_el8.10.0+4297+63ae3533
Fixed in
  • 2.4.9.4-9.module_el8.10.0+4297+63ae3533

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied immediately. Users should upgrade to cjose version 0.6.1-6.module_el8.10.0+4330+15616d81 and mod_auth_openidc version 2.4.9.4-9.module_el8.10.0+4297+63ae3533 or later as provided by Red Hat Enterprise Linux 8 updates. Refer to the Red Hat advisory RHSA-2026:92157 for detailed update instructions. No additional mitigations are indicated as the update fully addresses the issue.

Description

A critical security vulnerability (CVE-2026-53939) affects the mod_auth_openidc module for Apache HTTP Server, specifically in the cjose library used for OpenID Connect and OAuth 2.0 authentication. The flaw involves the use of an all-zero Content Encryption Key for AES-CBC-HMAC JSON Web Encryption (JWE), which compromises encryption security. This vulnerability is fixed in updated versions of the cjose and mod_auth_openidc packages.

References

Community reviews

Loading reviews…