CVE-2026-89058: Important · dogtag-pki security update
Affects idm-pki-acmeSource GCVE Database
Not known to be exploited · CVSS 7.4 High : upgrade to 11.9.0-6.el10_2.1.alma.1 soon.
Data as of 30 Oct 2026, 14:23 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 7.4 |
|---|
- Patch
- Available – fixed in 11.9.0-6.el10_2.1.alma.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the AlmaLinux to 11.9.0-6.el10_2.1.alma.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10idm-pki-acme | Affected
| Fixed in
|
| AlmaLinux 10idm-pki-base | Affected
| Fixed in
|
| AlmaLinux 10idm-pki-ca | Affected
| Fixed in
|
| AlmaLinux 10idm-pki-java | Affected
| Fixed in
|
| AlmaLinux 10idm-pki-kra | Affected
| Fixed in
|
| AlmaLinux 10idm-pki-server | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied to affected systems. The fixed version is 11.9.0-6.el10_2.1.alma.1. Refer to the Red Hat advisory RHSA-2026:92408 for detailed update instructions. Applying this update mitigates the described vulnerabilities.
Description
A security update for dogtag-pki addresses multiple vulnerabilities including a Cross-Origin Resource Sharing (CORS) misconfiguration in RESTEasy's CorsFilter (CVE-2026-89058), which reflects arbitrary origins with credentials under wildcard configuration. The update also fixes other denial-of-service vulnerabilities in related components. The affected software is IdM PKI, an enterprise Public Key Infrastructure management system. The vulnerability is rated as important by Red Hat and affects versions prior to 11.9.0-6.el10_2.1.alma.1.
References
- access.redhat.com/errata/RHSA-2026:92408 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-89058 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-89059 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-89407 (opens in a new tab)
- bugzilla.redhat.com/2519756 (opens in a new tab)
- bugzilla.redhat.com/2519775 (opens in a new tab)
- bugzilla.redhat.com/2538720 (opens in a new tab)
- errata.almalinux.org/10/ALSA-2026-92408.html (opens in a new tab)