Skip to main content
VulnerabilityPublished Updated

CVE-2026-93543: libXi security update

Affects libXiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-93543· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 1.8.1-7.el10_2.1 soon.

Data as of 30 Oct 2026, 02:01 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.1-7.el10_2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.8.1-7.el10_2.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10libXiAffected
  • <1.8.1-7.el10_2.1
Fixed in
  • 1.8.1-7.el10_2.1
AlmaLinux 10libXi-develAffected
  • <1.8.1-7.el10_2.1
Fixed in
  • 1.8.1-7.el10_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available and should be applied. Red Hat Enterprise Linux 10 users should update libXi to version 1.8.1-7.el10_2.1 or later. Refer to the Red Hat advisory RHSA-2026:91004 and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps. No additional mitigation is required beyond applying the official patch.

Description

A denial of service vulnerability exists in the X.Org X11 libXi runtime library due to an out-of-bounds read in the XI2 class parser. This issue is tracked as CVE-2026-93543 and affects versions of libXi prior to 1.8.1-7.el10_2.1. The vulnerability has been rated with moderate severity by Red Hat. A security update fixing this issue is available for Red Hat Enterprise Linux 10 and related variants.

References

Community reviews

Loading reviews…