Skip to main content
VulnerabilityPublished

CVE-2026-112257: gimp:2.8 security, bug fix, and enhancement update

Affects gimpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-112257· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 2:2.8.22-26.module_el8.10.0+4352+8516153e.10 : patch gimp soon.

Data as of 5 Nov 2026, 13:06 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.8
Patch
Available – fixed in 2:2.8.22-26.module_el8.10.0+4352+8516153e.10, 2.28.7-5.module_el8.10.0+4267+35168c80, 2.28.7-5.module_el8.10.0+4175+c208a0bf +6
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AlmaLinux 8gimpAffected
  • <2:2.8.22-26.module_el8.10.0+4352+8516153e.10
Fixed in
  • 2:2.8.22-26.module_el8.10.0+4352+8516153e.10
AlmaLinux 8gimp-develAffected
  • <2:2.8.22-26.module_el8.10.0+4352+8516153e.10
Fixed in
  • 2:2.8.22-26.module_el8.10.0+4352+8516153e.10
AlmaLinux 8gimp-devel-toolsAffected
  • <2:2.8.22-26.module_el8.10.0+4352+8516153e.10
Fixed in
  • 2:2.8.22-26.module_el8.10.0+4352+8516153e.10
AlmaLinux 8gimp-libsAffected
  • <2:2.8.22-26.module_el8.10.0+4352+8516153e.10
Fixed in
  • 2:2.8.22-26.module_el8.10.0+4352+8516153e.10
AlmaLinux 8pygobject2Affected
  • <2.28.7-5.module_el8.10.0+4267+35168c80
Fixed in
  • 2.28.7-5.module_el8.10.0+4267+35168c80
AlmaLinux 8pygobject2Affected
  • <2.28.7-5.module_el8.10.0+4175+c208a0bf
Fixed in
  • 2.28.7-5.module_el8.10.0+4175+c208a0bf

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected systems. Red Hat has released updated packages for GIMP that fix this vulnerability. Users should update to the fixed versions listed in the advisory to remediate the issue. No additional mitigation steps are indicated beyond applying the official update.

Description

A heap out-of-bounds read/write vulnerability exists in the PSD thumbnail loader component of GIMP (GNU Image Manipulation Program), identified as CVE-2026-112257. This flaw affects multiple versions of GIMP prior to the fixed releases. The vulnerability could lead to memory corruption during processing of PSD thumbnails. An update addressing this issue is available and has been released by Red Hat for affected versions.

References

Community reviews

Loading reviews…