CVE-2025-46817: redis:6 security update
Affects redisSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · public detection template (Nuclei) : upgrade to 6.2.20-1.module_el8.10.0+4056+739731b0 soon.
Data as of 29 Oct 2026, 23:08 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.2.20-1.module_el8.10.0+4056+739731b0
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: evidence found.
nuclei template: Redis < 8.2.1 lua script - Integer Overflow
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 6.2.20-1.module_el8.10.0+4056+739731b0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8redis | Affected
| Fixed in
|
| AlmaLinux 8redis-devel | Affected
| Fixed in
|
| AlmaLinux 8redis-doc | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied promptly. The fixed version is 6.2.20-1.module_el8.10.0+4056+739731b0. Refer to the Red Hat advisory RHSA-2025:19238 and the update article https://access.redhat.com/articles/11258 for detailed patching instructions. No additional mitigations are indicated beyond applying the official update.
Description
Redis 6 contains multiple security vulnerabilities related to its Lua scripting engine, including integer overflow leading to potential remote code execution (CVE-2025-46817). Authenticated users could execute Lua scripts as different users (CVE-2025-46818), and specially crafted Lua scripts can cause denial of service (CVE-2025-46819). Additionally, a Lua use-after-free vulnerability may lead to remote code execution (CVE-2025-49844). These issues have been addressed in Redis version 6.2.20-1.module_el8.10.0+4056+739731b0.
References
- access.redhat.com/errata/RHSA-2025:19238 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46817 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46818 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46819 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-49844 (opens in a new tab)
- bugzilla.redhat.com/2401258 (opens in a new tab)
- bugzilla.redhat.com/2401292 (opens in a new tab)
- bugzilla.redhat.com/2401322 (opens in a new tab)
- bugzilla.redhat.com/2401324 (opens in a new tab)
- errata.almalinux.org/8/ALSA-2025-19238.html (opens in a new tab)