CVE-2025-46817: redis:7 security update
Affects redisSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · public detection template (Nuclei) : upgrade to 7.2.11-1.module_el9.6.0+188+92104ce8 soon.
Data as of 4 Nov 2026, 18:43 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 7.2.11-1.module_el9.6.0+188+92104ce8
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: evidence found.
nuclei template: Redis < 8.2.1 lua script - Integer Overflow
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 7.2.11-1.module_el9.6.0+188+92104ce8.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9redis | Affected
| Fixed in
|
| AlmaLinux 9redis-devel | Affected
| Fixed in
|
| AlmaLinux 9redis-doc | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately. The fixed version is 7.2.11-1.module_el9.6.0+188+92104ce8. Refer to the vendor advisory at https://access.redhat.com/errata/RHSA-2025:19345 and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps. No additional mitigations are indicated by the vendor advisory.
Description
Multiple security vulnerabilities have been identified in Redis 7 related to its Lua scripting functionality. These include an integer overflow that may lead to remote code execution (CVE-2025-46817), the ability for authenticated users to execute Lua scripts as different users (CVE-2025-46818), denial of service via crafted Lua scripts (CVE-2025-46819), and a use-after-free vulnerability in Lua that may also lead to remote code execution (CVE-2025-49844). A security update addressing these issues is available in Redis version 7.2.11-1.module_el9.6.0+188+92104ce8.
References
- access.redhat.com/errata/RHSA-2025:19345 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46817 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46818 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-46819 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-49844 (opens in a new tab)
- bugzilla.redhat.com/2401258 (opens in a new tab)
- bugzilla.redhat.com/2401292 (opens in a new tab)
- bugzilla.redhat.com/2401322 (opens in a new tab)
- bugzilla.redhat.com/2401324 (opens in a new tab)
- errata.almalinux.org/9/ALSA-2025-19345.html (opens in a new tab)