CVE-2025-43343: webkit2gtk3 security update
Affects webkit2gtk3Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.50.1-1.el8_10 as a priority.
Data as of 29 Oct 2026, 23:43 UTC
- Patch
- Available – fixed in 2.50.1-1.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 2.50.1-1.el8_10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8webkit2gtk3 | Affected
| Fixed in
|
| AlmaLinux 8webkit2gtk3-devel | Affected
| Fixed in
|
| AlmaLinux 8webkit2gtk3-jsc | Affected
| Fixed in
|
| AlmaLinux 8webkit2gtk3-jsc-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied to affected systems. The fixed version is webkit2gtk3-2.50.1-1.el8_10. Users should follow Red Hat's update instructions at https://access.redhat.com/articles/11258 to remediate this issue.
Description
A security vulnerability (CVE-2025-43343) in webkit2gtk3 was identified where processing maliciously crafted web content may cause an unexpected process crash. This vulnerability affects versions of webkit2gtk3 prior to 2.50.1-1.el8_10. A security update fixing this issue is available from Red Hat.