CVE-2026-106245: webkit2gtk3 security update
Affects webkit2gtk3Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.54.2-0.el9_8.1 when convenient.
Data as of 30 Oct 2026, 02:00 UTC
- Patch
- Available – fixed in 2.54.2-0.el9_8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 2.54.2-0.el9_8.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9webkit2gtk3 | Affected
| Fixed in
|
| AlmaLinux 9webkit2gtk3-devel | Affected
| Fixed in
|
| AlmaLinux 9webkit2gtk3-jsc | Affected
| Fixed in
|
| AlmaLinux 9webkit2gtk3-jsc-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 2.54.2-0.el9_8.1 of webkit2gtk3 is available and should be applied to affected Red Hat Enterprise Linux 9 systems. Users should update their packages promptly following Red Hat's advisory instructions. No additional mitigation steps are indicated beyond applying the official patch.
Description
WebKitGTK, the GTK port of the WebKit rendering engine, has multiple security vulnerabilities in its ANGLE component, including use-after-free, out-of-bounds read/write, buffer overflow, type confusion, and uninitialized resource issues. These vulnerabilities affect versions prior to 2.54.2-0.el9_8.1 and have been addressed in the fixed release 2.54.2-0.el9_8.1. The update is rated as Important by Red Hat and applies to Red Hat Enterprise Linux 9 variants.
References
- access.redhat.com/errata/RHSA-2026:91580 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-106245 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-106247 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-106293 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-106304 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-95325 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-95331 (opens in a new tab)
- bugzilla.redhat.com/2543413 (opens in a new tab)
- bugzilla.redhat.com/2543421 (opens in a new tab)
- bugzilla.redhat.com/2546829 (opens in a new tab)
- bugzilla.redhat.com/2546942 (opens in a new tab)
- bugzilla.redhat.com/2546956 (opens in a new tab)
- bugzilla.redhat.com/2546958 (opens in a new tab)
- errata.almalinux.org/9/ALSA-2026-91580.html (opens in a new tab)