zookeeper · Improper Handling of Exceptional Conditions
Affects zookeeperSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 3.8.8 soon.
Data as of 4 Nov 2026, 15:17 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 8.7 |
|---|
- Patch
- Available – fixed in 3.8.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.zookeeper/zookeeper to 3.8.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to version 3.8.8 or 3.9.7, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.
Description
A vulnerability in Apache ZooKeeper's quota subsystem allows unauthenticated attackers on default configurations to write to a world-writable subtree, causing the server's critical request-processing thread to crash and rendering the on-disk data directory permanently unbootable. This affects Apache ZooKeeper versions up to and including 3.9.6. Upgrading to versions 3.8.8 or 3.9.7 resolves the issue.